Due to various factors, it can happen that websites cannot be analyzed. To guarantee a successful analysis for you, we have summarized the most common reasons and recommended actions below.

Please compare your current setup with the mentioned causes and follow our suggested steps to solve this problem.

(Attention: Free Customer have no access to the mentioned settings)

1) The specified homepage does not allow the crawler bot proper access to the website.

This happens if the defined home page is different from the URL that appears in the browser. Most of the time, the submitted version is not indexable (i.e. it does not have the technical requirements to be listed on Google).

The solution is simple: just define the correct version of the start page. If you want to test and solve this problem, I would like to show you how it can be done here:

2) The selected bot is denied access

This also often results in the fact that no Links can be found in a test crawl (see video above). In such a case you can change the crawler bot in the project settings at How to analyze.

For example, try the Googlebot as an alternative.

3) Our crawler is completely blocked by your domain

In such a case we receive the status code 403 (forbidden) in a test crawl. This means that our crawler simply does not get permission to analyze your site. Try to change the crawler bot in this case as well. If this does not solve the problem, please put our RyteBot on your whitelist. Once this is done, the analysis should work.

4) An Analytics Property is defined for which you no longer have access

If you have established a connection to Google Analytics, this is the first point of contact between our crawler and your website. However, if access rights have already been revoked, our crawler cannot get past the lack of permissions. This happens rather rarely but is easy to solve.

Remove the linked Analytics Property in the project settings under Google Services and + Settings and then try the analysis again.

5) Your white- or blacklist settings are blocking our bot from access

In such a case you have used our Include or exclude URLs option to analyze only a certain area of the website. However, if the rules were set incorrectly, you will receive either a status code with a 9 at the beginning or the message Blocked due Whitelist I Blacklist setting

Here you can find out how to set the rules correctly:

https://support.ryte.com/hc/en-us/articles/360000677583-Using-the-blacklist-and-whitelist-ignore-or-include-URLs-

Should none of the points lead to a solution,

please feel free to contact our support so that the case can be checked in detail.

For customers of our Basic and Business Suite, this can be done quickly and easily via our In-Tool Chat on the bottom right.

Did this answer your question?